Record Editor User Guide


Version 4.2.349.0

1. Introduction to the Record Editor

The Record Editor is a UI tool for viewing and editing data file contents. It also provides the functionality of modifying specific metadata.

The primary purpose of the Record Editor is to handle files organized in a record-based format. The Record Editor provides functionality similar to the mainframe systems, allowing you work with data files as a sequence of records.

The Record Editor can:

  • Display data file contents as records

  • Edit records

  • Display records in terms of fields, including showing fields vertically

  • Edit records field-wise according to the declaration description

  • Search in records

  • Search in fields

  • Display and modify certain metadata

  • Export records

  • Work with files outside the Catalog

1.1. How to launch the Record Editor

The Record Editor can be launched in several ways. Launch it from the Start menu or the Desktop as any regular Windows Application. You can also launch it from the Windows Command Prompt (cmd). When the Record Editor is launched from cmd, it accepts two parameters, MetaFile and CodePage. Below mentioned is an example of how you can pass these parameters:

RecordEditor.exe -MetaFile="C:\ProgramData\Raincode\Batch\DefaultVolume\LARGE\FB\NR5k.meta"

Additionally, the Record Editor opens when a user edits a file in the Catalog Explorer. For more details on launching the Record Editor from the Catalog Explorer, refer to the Catalog Explorer documentation.

2. The Record Editor Interface

maindisplay
Figure 1. Main Display

The main screen of the Record Editor has the following elements:

1. Menu bar

2. Toolbar

3. Navigation bar

4. Search bar

5. Records area

6. Status bar

To open a data file in the Record Editor, you must open its corresponding .meta file. The Record Editor will internally communicate with the Catalog Manager and open an appropriate data file corresponding to the .meta file you opened, such as an a.seq file. For more details on the Raincode Catalog Manager, refer to the Raincode JCL User Guide.

recordeditor
Figure 2. Record Editor
Data files can have various file extensions such as .seq, .dat, .rr or a configured extension. The default display mode is the Record mode.

To open a data file in the Record Editor, follow these steps:

1. From the toolbar, select File→Open (Ctrl+O) or click the Open crop button, and a dialog box will appear

openmetadatafile
Figure 3. Open metadata file

2. Select the appropriate metadata file. The Record Editor will load the corresponding data file.

metadatafileinrecordeditor
Figure 4. Metafile in the Record Editor
Uncheck hexa to see the hexadecimal values.
metadatafilewithhexadecimal
Figure 5. Metafile with hexadecimal values in the Record Editor

You can add the first record if the file has no record. To add the record, you have to enable editing by clicking the turn on editing icon edit on the toolbar. It will activate the Click here link, and the lock status on the bottom of the Status Bar will indicate that the file is locked for editing. Refer to, Turn on the editing for more details on the feature.

addrecord
Figure 6. Add records

2.1. Open without the batch locking

When you open a file, the Record Editor uses the Catalog.configuration.xml to retrieve the file in the catalog and apply a lock when you modify it. Applying the lock is required to avoid modifying a file by the Record Editor currently used by a running batch.

If it fails to acquire a lock, the Record Editor will show an error, as shown in the screenshot below.

Exclusivelock
Figure 7. Exclusive Lock error

Open without batch locking is a way to bypass the batch locking mechanism. Open without batch locking also enables opening a file outside the catalog context (you do not need to have the catalog.configuration.xml associated).

Select Tools→Open without batch locking…​, to open a data file without batch locking.

If you open the file without batch locking and try to edit it, a pop-up will appear, as shown in the screenshot below.

datadiscard
Figure 8. Edit without Batch Locking

2.2. Error opening data file

If the Record Editor attempts to open the data file, which is in use by another process, you will encounter an error, as shown in the screenshot below.

blockingprocess
Figure 9. Data file blocked by another process

On clicking Yes, the Record Editor launches the application pointed by BlockingProcessInfoGetterPath with parameters as shown below:

<BlockingProcessInfoGetterPath> -MetaFile=<metafile path> -DataFile=<datafile path>

The Record Editor waits for output for a given period and shows it when received. It captures and shows both Standard output and error. The Record Editor shows a time-out error if the application does not return in a given time. You can cancel the operation by clicking the cross1 button on the progress bar. For more details, refer to BlockingProcessInfoGetterTimeOut in the Record Editor configuration file table.

The file handle stays open in the Record Editor only during read/write operations. Otherwise, the file handle stays closed internally, making it available for other processes. If you suspect the file handle is opened in the Record Editor, you can use Tools → Close File. This option will not work when Edit Mode is on.

attemptfileclose
Figure 10. Attempt data file close

If the data file is reported as being used by another process, you can get information on the blocking process using Tools → Locking Application Info.

2.3. Change Catalog Configuration

The Record Editor provides the flexibility of choosing a different catalog from the one loaded by default. You can do this by selecting the appropriate catalog configuration file.

To select the configuration file:

  • Select Tools→ Change Catalog Configuration

catalog configuration
Figure 11. Change Catalog Configuration

You can also change the catalog configuration File location from Tools→ Options…​

catalog configuration1
Figure 12. Change the Catalog Configuration File location

2.4. File Details

Files details provide:

  • Data File: Full path of the data file and the data file size.

  • File Info: Values of File Organization and Record Size. This information comes from the metafile.

  • Encoding: Code Page value and Encoding Name. The Record Editor begins with a default value of 1252 for the Code Page.

If the Record Editor launches through the Catalog Explorer, the Code Page value comes from the catalog. If you modify and save the Code Page, the modified value will override the value from the catalog.

Select File→File Details from the toolbar or click the File Details filedetails icon on the toolbar.

For example, the screenshot below shows that the File Organization is Sequential, the Record Size is 110, the Code Page is 1252, and the Encoding Name is Western European (Windows).

filedetailshow
Figure 13. File details
File organization types are LineSequential, Sequential, Indexed, and Relative.

2.4.1. Modify Record Size

  • To modify the record size, check to modify and enter the desired record size.

modify
Figure 14. Edit record size
  • Click saveandreload to save and reload the file with a modified record size value.

  • If you do not want to save the modified record size, click on reloadfile.

A red asterisk (*) on the top right corner of the record size box indicates that the modified record size has not been saved.

2.4.2. Modify Encoding Details

  • Select the required encoding from the drop-down menu of the code page.

  • Click reloadfile to load the file with the new encoding.

2.5. Export

To Export the records, select File→Export. A window will open with options, as shown in the screenshot below.

Windowsexport
Figure 16. Options of Export
Options like filtered records and CSV will be disabled initially.

Options provided in the Export are:

  1. Export

    • Whole file

    • Current page

    • Filtered records

  2. End-of-line characters

    • CRLF-Carriage return line feed

    • CR- Carriage return

    • LF- Line feed

  3. Output format

    • txt

    • CSV

  4. CSV Options

    • Delimiter

      • Comma

      • Semicolon

      • Tab

      • Space

      • Other

    • Include header row

    • Include quotation marks

  5. Output

    • Status - It shows the status of the Export.

      • Not exported

      • Exporting

      • Export cancelled by the user

      • Export completed successfully

    • File Path - The path of the exported file. You can choose the path by clicking on the change1.

    • Exported records- Total Number of the Exported records.

Once you have selected the Export options, click on start1 to start the Export, and a pop-up window will appear, as shown in the screenshot below.

exporttime
Figure 17. Export time

Once you click OK, the Export will begin.

After the Export is successful, a pop-up window stating the Export has been completed successfully will appear.

exportsuccess
Figure 18. Export- Successful

The output will be updated, as shown in the screenshot below.

exportoutput
Figure 19. Export-Output

You can choose to cancel the Export in the middle of the process. Once you select the option to Start Export, a progress bar will appear if the number of records is large, as shown in the screenshot below. Click on the cross1 to cancel the Export.

Progressbarforexport
Figure 20. Export Progress bar

As shown in the screenshot below, a popup window will appear, asking for your confirmation.

exportcancel
Figure 21. Export Cancel

Once you click Yes, the Export will be cancelled, and the status of your action will get updated in the output as Export cancelled by the user.

exportcancelledbyuser
Figure 22. Export cancelled by the user

Filtered Records Export

Once you enter the keywords for the filter in the search box, the Export wizard will automatically apply the filter, enabling the filtered records. In this scenario, only the filtered records will be exported.

As you can see in the screenshot below, ghi is the keyword for the filter, and filtered records are enabled.

filteredrecord1
Figure 23. Filtered record-Export

CSV Options

The CSV options are enabled in the field mode. To export in the CSV, select File→Export and choose csv as the output format.

csvoptions
Figure 24. CSV options

2.6. Save Settings and Load Last Saved Settings

After modifying the settings, select Tools→Save Settings to save them; you can also load the last saved settings by selecting Tools→Load Last Saved Settings.

The following settings are saved:

  • Page Size

  • Hide Hex Values

  • Code Page

  • Log Level

  • Log file location

  • IO (Cache size)

  • Chunk size for long record

  • Keyboard step size for long record

  • Number of maximum fields displayed

  • Options for Copy/Paste:

    • Show repeated paste dialog

    • Show block paste dialog

    • Copy/paste decoded values

2.7. Logging

2.7.1. View Logs

Select Tools→View logs to view all the logs of the Record Editor.

2.7.2. Logging settings

The extent of logging can be modified by setting the log level to the appropriate value. You can turn off the logging by setting the log level as None.

Select Tools→Options…​, to change the settings of logs.

logfilesetting
Figure 25. LogLevel
  • Select the drop-down menu of the log level and select the required level.

Loglevel info
Figure 26. LogLevel info
  • Select the location of the log file by clicking on change. By default, the location of the log file is C:\User\abc\AppData\Local\Raincode\Logs.

The filename (RecordEditor.log) of the log file is fixed.
If the RecordEditor.log file is more than 1 MB when you start the Record Editor, the file will be archived at the exact location as RecordEditor1.log, RecordEditor2.log, and so on.

2.8. Record Navigation

Currently displayed records in the Record Editor are referred to as Page.

The Maximum number of records shown on one page is called Page Size.

Page Size can be modified by selecting the appropriate value from the page size drop-down menu.

pagesizebox
Figure 27. Page size drop-down menu
Page sizes are fixed numbers of 10, 25, 50, 100, 150, and 200.

A Navigation Bar is used to move to the desired page in a data file. It has the following buttons:

firstpagenav: show the first page

prevpage: show the previous page

navibutton: go to the desired page

nextpage: show the next page

lastnav: show the last page

Go to page action depends on the Page Size. For example, if the Page size is 50 pagesize and the Go to this page value is 2 navibutton, then by clicking the go button, the tool will display records beginning from the record number 51.

Go to page box will turn red if you click somewhere else on the Record Editor after entering the value and without applying it (by pressing enter or pressing go).

redgo
Figure 28. Go to page

Any navigation actions may show a progress bar if it takes considerable time to complete the action. The action can be aborted by clicking the cross button on the right side of the progress bar.

progressbar1
Figure 29. Progress bar

You can navigate within the records by using the Up and Down arrow keys. This allows you to go one record at a time.

Pressing the Page Up and Page Down buttons navigates ten records simultaneously.

Show the previous page will be disabled if the file organization type is sequential.

2.9. Show record vertically

The Record Editor lets you see the records vertically in the Field Mode.

  1. By default, the Record option in the menu bar is disabled. To enable it, select any of the records.

  2. Select Record→Show Record Vertically or click RV in the toolbar. The selected record will be displayed vertically, as shown in the screenshot below.

verticaldisplayofrecord
Figure 30. Selected Record Displayed Vertically

Using arrows, you can navigate through the records in the vertical display.

To edit the records, click the turn on editing editrecord icon; after editing, click saveV to save the changes.

Using Align, you can align the records left, center or right.

As shown in the screenshot below, all the records are left-aligned.

Left
Figure 31. Left-aligned records
A blue arrow BA in the record number box represents the current record.

Editing of records is synchronous between two displays. For example, if you edit the vertically displayed record, it will update horizontally and vice-versa.

You can also edit the Field Value as well as the Hex Value. If you have updated the Field value, the Hex Value will be updated accordingly.

Record numbers 4, 6 and 13 are selected for editing; in the figure Edit record,

editarecord
Figure 32. Edit record
recordno1 at the left corner, provide the number of the currently displayed record.

The Record Editor allows you to search and filter the datasets.

searchbar1
Figure 33. Search bar
Search is case-sensitive.

2.10.1. Search by record number

Navigation by record number will move to the appropriate page depending on the Page Size. For example, if the Page Size is 50 and the desired record number is 53, the tool will display page number 2 and place the mouse pointer in record 53.

2.10.2. Search by content

Type the search term in the search box and press enter.

The tool will display the matching record by automatically adjusting the record area’s scroll bar and highlighting the matching record content.

Click the next match button next or F3 to see the next match.

Click the search last occurrence button lastoccur to search the last occurrence of the search term entered.

Click the clear search button cross to clear the search.

Click the filter filter to display the records matching the search term entered. After applying the filter, a tooltip will show you the search term entered if you hover the mouse on the filter button.

filtervaluetooltip
Figure 35. Tooltip showing search term entered

The search/filter will begin from the beginning. If you want to change it, select tools and uncheck the option searchfilterfrombeginning or toggle enablesearch on the search bar to enable or disable search/filter from the beginning.

The Record Editor allows you to do a pattern-matching search. It follows the .Net regular expression rules.

Click pattern on the search bar to enable the pattern matching search.

For example, the search term a…​d will match content abcd.

The Record Editor allows you to stay on the current page if search results are not found rather than moving to the last searched page.

stayback
Figure 37. Stay on the current page

The same option will also be available when you cancel the search.

searchcancelled
Figure 38. Search cancelled

The option to stay on the current page is also provided when filtering the datasets.

Once the search begins, the behaviour of the navigation buttons changes as mentioned below:

  • Show first page firstpagenav changes to search from the first page.

searchfromfirstpage
Figure 39. Search from the first page
  • Show next page nextpage changes to search from the next page.

searchfromnextpage
Figure 40. Search from the next page
  • Show previous page previouspage changes to search from the previous page.

searchfrompreviouspage
Figure 41. Search from the previous page
  • Show last page lastnav changes to search from the last page.

searchfromlastpage
Figure 42. Search from the last page

2.10.4. Hexadecimal Search

To perform the Hexadecimal search, uncheck the hexa on the toolbar. All the hex values will be displayed in the Records Area.

Toggle the Hexadecimal search icon hexaicon to activate the hexadecimal search.

Once the hexadecimal search is on, enter the hex value to search and press the Next match next.

hexaviewdisplay
Figure 43. Hexadecimal Search

2.10.5. Search and replace

Type the search term in the box, and click the search and replace button searchandreplace. Enter the value to replace; replace once replaceonce or replace all replaceall will be activated.

Entervaluetoreplace
Figure 44. Enter the value to replace

When you press replace once replaceonce, it will replace the match, and the corresponding record will be marked as edited.

ReplaceOnce1
Figure 45. Replace once

The screenshot above shows that the search term ijk is replaced once with abc.

When you press replace all replaceall, it will replace all the matches, and the corresponding records will be marked as edited.

ReplaceAll1
Figure 46. Replace All

The screenshot above shows that the occurrence of the search term ijk is replaced everywhere with abc.

Replace Once/Replace All buttons get enabled when the lengths of the search and replace terms are the same.

2.11. Records Area

As shown in the Record Editor Interface, the Records Area displays the data file’s content in the form of records.

Recordnumber1
Figure 47. Record Area

A record has three sections:

  1. Record Number: shown on the left side

  2. Decoded Record Content: shown on the top right side

  3. Binary Record Content: shown in the hexadecimal on the bottom right side, broken into the high and low nibbles. In the figure record area, the Hexadecimal value 30 is shown as 0 using ASCII encoding, and high nibble 3 and low nibble 0 are placed as marked in Red.

Encoding details (code page) are used to decode binary values. If the decoded value has a non-printable character, it is displayed as an interpunct character.

2.12. Status Bar

The status bar at the bottom of the screen shows the following information in the different sections:

  • The current execution status of the Record Editor

  • The current value of the code page

  • Last user action and its result: Red indicates an error, orange indicates a warning, and black signifies normal circumstances.

  • Column Number

  • Lock Status

statusbar1
Figure 48. Status Bar

3. Display Modes

The Record Editor lets you view and edit the records in two display modes: Record Mode and Field Mode.

Click on the switch mode buttons switchmode or switchmode1, as applicable, to switch from one mode to another.

3.1. Record Mode

recordmodeview
Figure 49. Record Mode

3.2. Field Mode

Field Mode shows fields within the records. The resultant view looks like a spreadsheet made up of rows and columns. The fields are shown per your chosen variable, extracted from the declaration description. There are three ways the Record Editor can get the declaration description.

  1. From the COBOL file

  2. From the COBOL Copybook file

  3. From the declaration descriptor XML file

fieldmodeview
Figure 50. Field Mode

In the case of COBOL and COBOL Copybook files, the Record Editor extracts (using CobRc.exe internally) the required information and creates the declaration descriptor XML file with name <input file> + .decl.xml and places it next to the input file for future use.

The COBOL compiler (cobrc) or the PL/I compiler (plirc) is used to parse a source file and generate a declaration descriptor XML file containing all the variables declared in the program.

The compiler is invoked with :DeclDescriptors to give the path to the output file and the source file:

  • cobrc :DeclDescriptors=path_to_xml.xml path_to_source.cbl

  • plirc :DeclDescriptors=path_to_xml.xml path_to_source.pli

You must select one of the above three types of files to switch to the Field Mode when a metafile is opened for the first time. The Record Editor saves this file name against the metafile and uses the same for the next opening of the same metafile. It can be changed if required.

To view records in the Field mode:

1. Click on the switch mode switchmode button, and an open file dialog will appear, asking for the file location for the variable names. Select the appropriate file type from the drop-down in the bottom right corner. The Record Editor preserves this file location mapped to the metafile.

locationofdescriptorfile
Figure 51. Pop up window

2. After the file for the variable names is selected, the Select variable name window appears.

If a data file has been opened in the Field Mode before, the Record Editor skips the open file dialog and shows the Select variable name window instead. It fetches the location of the previously used file for the variable names it preserved and uses. You can change it if required in the Select variable name window.
variablename
Figure 52. Variable Name
The drop-down menu of the variable names shows the list of all the available user-defined variables.

3. After you click the OK button on the Select variable name window, the Record Editor shows each record broken into the fields per the variable name selected. It shows the field name in the top row of the records area. It also places the variable name drop-down in the main toolbar if you wish to change the variable name.

Fieldmode
Figure 53. Field mode
You can view the HEX Value in the field tooltip in the field mode.
Navigating records in the field mode is done similarly to navigating records in the record mode. For more details, refer to the section Record Navigation.

3.2.1. Search in Field Mode

Most field mode search controls are the same as search in record mode, except field mode search will be done in each field.

Once you check searchselectedfields and hover over a field, a search icon will appear, which means you can select those fields for the search.

searchonselectedfields
Figure 54. Search on selected fields

When you hover over the field, it gives a tooltip with all the information regarding the variable.

hoveroverdatatype
Figure 55. Tooltip

You can select fitwidthtocontent on the toolbar to remove the white spaces between the data.

4. Handling files with a long record

When the Record Size exceeds the long record chunk size, the file is treated as a long record file in the UI of the Record Editor. Accordingly, the display shows elements to manage such a file. The display only shows a part of the long record called a chunk. You can set the long record chunk size by selecting tools and options. You can also set the long record keyboard step size, which means your display will move by the value mentioned in the long record Keyboard step size whenever you press the Ctrl + Right Arrow or Left Arrow.

contentbuffersize
Figure 56. Set Chunk size
The minimum and maximum value of the long record chunk size is 1000 and 9600.
The minimum and maximum value of the long record keyboard step size is 10 and 80.

You can set the Number of Maximum columns for the field mode.

The minimum and maximum value of the Number of Maximum columns displayed is 5 and 200.

4.1. Long record navigation

A long record is broken into chunks. So, when the file is loaded, the Record Editor shows the first chunk of every record, and the long record navigation toolbar appears at the bottom left of the Record Editor.

longrecordsdisplayed
Figure 57. Long records displayed

Using the long record navigation toolbar, you can navigate through the records.

longrecordnavigationtoolbar
Figure 58. Long record navigation toolbar

draganddrop: drag the long record navigation toolbar across the horizontal bar.

chunkdisplayed: displays the position of the chunk.

checklongrecord: makes the toolbar move with the horizontal bar.

movetoleftmost: moves the display to the leftmost.

movetonextleftchunk: moves the display to the next left chunk.

moveleft: moves the display by one column to the left.

moveright: moves the display by one column to the right.

movetonextrightchunk: moves the display to the next right chunk.

movetorightmost: moves the display to the rightmost.

The function of the long record navigation toolbar is the same for the record and field modes. In the record mode, it will help you navigate the records; in the field mode, it will help you navigate the fields.

longrecordnavigationtoolbarfieldmode
Figure 59. Long record navigation toolbar for field mode

5. Handling files with Variable Block

The Record Editor allows you to modify the individual record sizes of the record in the Variable Block files. When you open a Variable Block file, a column indicating the record size appears next to the record number column.

A checkbox in the title bar of the records size column allows you to modify the individual record sizes. By default, modification of the record size is disabled.

enablerecordsize
Figure 60. Disabled Record Size Modification

Once you have enabled the record size modification, the column with the record size will become editable.

enablerecordsize1
Figure 61. Enabled Record Size Modification

The record length of every record in a Variable Block file can be different. To modify the record size, select that particular record size and enter the value. Once you modify the value, a black rectangle will appear around that record size specifying that this record size has been modified. You can modify as many record sizes as you want.

modifiedrecordsize1
Figure 62. Modifying Record Size

Press saveall to save all the modified record sizes once modifying the record sizes is done. A popup window will appear asking you if you are sure that you want to save all Records Size Changes.

Press Yes in the popup window; all your record size modifications will be saved, and the record size modification will get disabled.

modifiedrecordsize
Figure 64. Modified record size

The checkbox gets disabled when you start modifying the record size value. If you want to discard your changes, you can edit them to the original value or choose File → Discard All Changes.

You cannot perform the regular edit functions when editing the record size and vice-versa. However, you can navigate between the records.

6. Edit Records

To edit the record, you have to enable the editing by clicking the turn on editing icon edit on the toolbar. The lock status in the bottom right of the Status bar will indicate that the file is locked for editing.

Further, when you hover the mouse over the record number space, an editing icon panel will appear:

Editing
Figure 65. Editing Icon Panel

Select the edit icon edit from the editing icon panel to edit the record’s content.

After selecting the edit icon, the Record Content Space will turn yellow for decoded values and orange for hexadecimal values.
Until editing is enabled, all the editing-related options will be disabled.
recordcontenteditmode
Figure 66. Record content in edit mode

Place the cursor on the content and edit it as required.

While editing the hexadecimal value, the pointer will automatically move from the top row to the bottom row. One top row character and one bottom row character make a byte in the hexadecimal value view.

Select save save from the editing icon panel to save the edited record.

After selecting save, the Record Content Space will resume to white and grey.
Once you select to save the records, the file will automatically get unlocked, which means you cannot edit until you turn on the editing.

Select discard discard from the editing icon panel to discard the changes.

Select delete delete from the editing icon panel to delete the record. Once you click on delete record, it will change to Red. To remove it from the list of displayed records, select saveall on the toolbar.

selectedrecordsfordelete
Figure 67. Selected records for delete

Select insert above insert or below inserta from the editing icon panel to insert a new record above or below your desired record number.

An empty row will appear, as shown in the screenshot below.

insertrowbeloworabove
Figure 68. Insert row below or above

Click on the empty row to enter the data for the record. You can copy/paste the content using a right-click and selecting copy/paste or the shortcuts Ctrl + Alt + C and Ctrl + Alt + V.

6.1. Edit Multiple Records

The Record Editor allows you to edit multiple records at the same time.

multiplerecords
Figure 69. Multiple Records

This tool also allows you to select the records that need to be modified in the range.

Following are the steps to select the records in the range:

  • Select the starting record, and from the Record menu, choose Beginselection.

  • Select the last record, and from the Record menu, choose Endselection.

selectedrecordsinrange
Figure 70. Selected records in the range

From the Record menu choose modifyrecord, to modify the selected records.

A few operations that you can perform on selected records are:

  • Edit

  • Delete

  • Cut

  • Copy

  • Clear Cut/Copy

  • Paste in the beginning of (Decoded Value or Hex Value)

  • Discard

contextmenumodify
Figure 71. Context menu of modify selected

There are two options to save edited records:

1. Save each record one by one by selecting Save from the Editing Icon Panel.

2. Select File→Save All Changes or select saveall on the toolbar.

Select File→ Discard All Changes to discard all the changes at once.

You can also increase the selection of the records. For example, selection starts at record number 5 and ends at record number 13, and you make some changes in non-selected records like record number 17 and record number 21. The Record Editor allows you to extend the selection by selecting the last record and choosing the Endselection from the Record menu.

beforeextendingtheselection
Figure 72. Before extending the selection
extendingtheselection
Figure 73. After extending the selection

Similarly, you can reduce the selection. For example, selection starts at record number 5 and ends at record number 13, and you want to reduce the selection to record number 10. You have to select record number 10 and then choose the option Endselection from the Record menu.

You can choose Removeselection from the Record menu to remove the selection of records whenever required.

6.1.1. Block Edit

Block Edit allows you to select many records in one shot and cut and paste them into another place.

Copy the records

From the Record menu, choose modifyrecord and select copy.

blockcopy
Figure 74. Block copy

To paste the record, choose to paste above or below from the Editing Icon Panel.

copyrecordabove
Figure 75. Paste copied records
recordpasted
Figure 76. Records pasted
You can paste the record on any page. The above screenshots show that the user has copied the records from Page 1 and pasted them onto Page 93.
Cut the records

From the Record menu, choose modifyrecord and select cut.

blockcut
Figure 77. Block cut

To paste the record, choose to paste above or below from the Editing Icon Panel.

pasterecordabove
Figure 78. Paste cut records
recordpasted1
Figure 79. Records pasted
You can paste the record on any page. The above screenshots show that the user has cut the records from Page 1 and pasted them onto Page 5.

Once you cut and paste the records, the selected cut records are marked to delete.

markedfordelete
Figure 80. Selected cut records marked to delete

You can clear the buffer by selecting clearcutcopy from the context menu of modifyrecord.

Buffercleared
Figure 81. Buffer cleared
When you copy the records, you can paste them any number of times until you clear the buffer. But when you cut the records, you can paste them only once.

6.1.2. Edit Displayed Record

The Record Editor allows you to edit currently displayed records. Select File→Edit Displayed Records from the File menu bar.

6.1.3. Turn On Global Edit

Global Edit functionality saves you time from clicking the Edit every time. Select File→Turn On Global Edit from the File menu bar, which makes all the records editable.

filemenubar
Figure 82. File menu bar

The Record Editor allows you to go on the previous and next pages with modifications. You can navigate by selecting show the previous page having modifications button previouspagem or show next page having modifications button nextpagem on the toolbar.

6.2. Edit Field

Fields are also edited in the same way as the records are edited.

editfield
Figure 83. Edit Field
You cannot edit hexadecimal values in the field mode since they are not displayed.

7. Copy and paste

To access the copy and paste options, select Tools → options.

advanceoptions
Figure 84. Options for copy/paste

7.1. Repeated paste

There may be a scenario where you want to paste a record more than once. In such a case, you can use Repeated Paste.

Press Ctrl + R to repeat the paste above the selected record or Ctrl + Shift + R to repeat the paste below the selected record.

Once you press the shortcut, a Repeated Paste dialog will appear, as shown in the screenshot below.

repeatedpaste
Figure 85. Repeated paste
The repeated paste is available for single record only.
The repeated paste is not available for copying from other instances.

To turn off showing the behaviour of showing a repeated paste window, uncheck show repeated paste option in the options for copy/paste

7.2. Copy/paste across instances

The Record Editor allows you to copy and paste the content across instances of the Record Editor.

Follow the following steps to copy from one instance to another:

  • Select the records and copy them from one instance of the Record Editor.

  • In another instance, press Ctrl + V, and a block paste dialog will appear; select the required options and press ok to paste the content.

blockpaste
Figure 86. Block Paste dialog

The Block paste provides you with the following options:

  • Source

    • Number of records - Total number of records copied by the user

    • Max record length - Maximum record length of the copied content

    • Record lengths - Record Lengths have three possible values:

      • Same- When all the copied records are of the same length

      • Variable - When all the copied records are of different lengths

      • N/A- When only one record is copied

    • Copy data

      • from beginning - copy from the beginning

      • till end - copy till the end

      • in range - select the range from which you want the record to be copied

  • Destination

    • Record length - A record length of the file

    • Recording mode - FB and VB

    • Paste data

      • from beginning - paste from the beginning

      • till end - paste till the end

      • in range - select the range for which you want the record to be pasted

      • Keep record lengths: as source or as destination

      • Fill Character - Fill the empty spaces with the selected character

If in range is not selected appropriately, the block paste will show an error. A Few of them are mentioned below:

  • The end index cannot be more than the max record length

  • The start index/End index cannot be empty

  • The start index cannot be bigger than the end index

  • The source range is narrower or wider than the destination range

  • The destination range is narrower or wider than the source range

If you select from beginning in the source and till end in the destination, it will automatically adjust in range value of the destination.

Example scenario of the block paste

  • Copy data from the beginning in the source and till the end in the destination:

As shown in the screenshot below, the user has selected to copy the record from the beginning in the source, and the max record length is 110. At the destination, the user has selected till the end and fill in character 41. So when paste happens, since the record length of the destination is 140, the initial characters are filled with 41(A), and the remaining are filled with the copied record from the source.

source destination
Figure 87. Example Scenario - The Block Paste
  • In Range:

As shown in the screenshot below, the user has selected to copy the data in range and fill in character 41. At the destination, the paste happens in the range of 1 to 110; since the record length of the destination is 140, the remaining characters are filled with 41 (A).

inrange
Figure 88. Example Scenario - The Block paste
Check Remember my choices and don’t show this again to avoid the block paste dialog on every paste.
The option to keep the record length as source or destination will appear when the file is in VB mode.

7.3. Copy/paste decoded values

The Record Editor, by default, always copies the hex value of the records. If you want to copy and paste the decoded value, check copy/paste decoded values.

8. Keyboard Shortcuts

8.1. Keyboard shortcuts for the Record Editor

Keyboard Shortcuts

Purpose

Ctrl + O

Open

Ctrl + S

Save All Changes

Ctrl + PgDn

Show Next page

Ctrl + PgUp

Show Previous page

Ctrl + Shift + S

Save Changes

Ctrl + Z

Discard Changes

Ctrl + N

Insert record above

Ctrl + Shift + N

Insert record below

Ctrl + C

Record copy

Ctrl + X

Record cut

Ctrl + V

Paste copied/cut record(s) above

Ctrl + Shift + V

Paste copied/cut record(s) below

Ctrl + E

Edit

Del

Delete

Ctrl + Alt + C

Copy the content of the record

Ctrl + Alt + V

Paste the content of the record

Ctrl + M

Begin selection of the records

Ctrl + Shift + M

End selection of the records

Ctrl + U

Remove selection

Ctrl + R

Repeated Paste Above

Ctrl + Shift + R

Repeated Paste Below

F1

About

8.1.1. Keyboard shortcuts for navigating the long records

Keyboard Shortcuts

Purpose

Ctrl + Right Arrow

Moves the display right by the value mentioned in the long record keyboard step size

Ctrl + Left Arrow

Moves the display left by the value mentioned in the long record keyboard step size

Ctrl + Home

Moves the display to the left most

Ctrl + End

Moves the display to the rightmost

Ctrl + Shift + Left Arrow

Moves the display to the next left chunk

Ctrl + Shift + Right Arrow

Moves the display to the next right chunk

Alt + Left Arrow

Moves the display by one column to the left

Alt + Right Arrow

Moves the display by one column to the right

Shift + Alt + C

Copy entire values

Shift + Alt + V

Paste in the entire values

9. The Record Editor Configuration

The Record Editor configuration file (RecordEditor.exe.config) combines the following tags, as shown in the table below. It is placed in the default installation directory: C:\Program Files\Raincode\Catalog.

Table 1. The Record Editor Configuration File
Tags Types Description Default Value Possible Values

RecordsPerPage

Integer

The number of records per page

50

10-200

HideHexValues

Boolean

Hide or show hex values on the record editor display

true

true or false

CodePage

Integer

The default code page to show file data

1252

Valid code page number

LogFileDirectory

String

Log file directory

Writable folder location

LogLevel

String

Level of log details

Info

Info, Warning, Error, and None

IOCacheSize

Integer

IO cache size

2048

2048

InspectFromBeginning

Boolean

Turn on or off inspecting file from the beginning

true

true or false

CobRcPath

String

Path to the Raincode COBOL compiler

bin\cobrc.exe

CobRcCobOptions

String

:DeclDescriptors

CobRcCpyOptions

String

Cobol compiler execution options, used while generating declaration descriptor XML from COBOL copybook file

:DeclDescriptors

LongRecordChunkSize

Integer

Chunk size of the long record files. For more details, refer to Handling files with a long record

1000

1000-9600

LongRecordKBStepSize

Integer

Keyboard step size for long record file. For more details, refer to Handling files with a long record

10

10-80

FieldModeMaxColumns

Integer

Maximum columns displayed in the field mode

10

ShowRepeatPasteDialog

Boolean

Toggle showing Repeat Paste dialog

true

true or false

BlockPasteCopyDataFrom

Integer

Specify copy source details for Block paste

1

1,2,3

where

1: from beginning

2: till end

3: in range

BlockPastePasteDataTo

Integer

Specify paste destination details for Block Paste

1

1,2,3

where

1: from beginning

2: till end

3: in range

BlockPasteKeepRecordLengthsAs

Integer

Specify which record length to consider for Block Paste

1

1,2

where

1: Source

2: Destination

ShowBlockPasteDialog

Boolean

Toggle showing Block Paste dialog

true

true or false

CopyPasteDecodedValues

Boolean

Enable copying of decoded values

false

true or false

BlockingProcessInfoGetterPath

String

The absolute path of utility (executable file) that takes a file path as a parameter and returns the owner of the current lock-in stdout

The Record Editor launches it with following parameters: -MetaFile="<meta file path>" -DataFile="<data file path>"

BlockingProcessInfoGetterTimeOut

Integer

The amount of time in milliseconds the Record Editor waits for process pointed by BlockingProcessInfoGetterPath to exit

15000

Appendix A: Lists of tables and figures in the document

This appendix includes the automated lists of the tables and figures available in this document, allowing you to access core information regarding the Raincode Record Editor more readily upfront and as an aide-memoire.